
Applying Buttons, Movie Clips, Graphics, and Text to a New Website Layout

Phase 1
Open the Flash program.
Press Ctrl+n to create a new file.
Choose ActionScript 2.0

Change the ESSENTIALS tab in the top right corner to ANIMATOR, to make things easier for you to 
navigate around.

Double check to make sure your timeline is set to 24 frames per second.



In the Properties window to your right, change the dimensions of your stage by pressing the Edit 
button.

1280 x 720 will be our canvas size for this project.

Click OK.

Now we’re all set!



1. Create a couple new layers.
Rename the bottom layer “background” (double click on the text of the layer to rename it).

Zoom out (press M, then hold down ALT and click on the stage) now you can see all four corners 
clearly.

Choose the Rectangle tool.

Go to the stage and click and drag from one corner to the next, cover all the white of the canvas.



2. Now to customize the paint of this backdrop.
Go to the far left and in the Color tab, choose Radial for your Type.

Now click on the first color tab to pick a new color for the start of your gradient.



After choosing your two different colors, you can now grab the Paint Bucket tool and paint the 
rectangle with it.

Wherever you click, that’s where the gradient will begin.



3. You’ve got a nice and simple background happening, so now we can make some buttons.
First, LOCK the background layer.
Rename the second layer “buttons”.

Select the Text tool from the toolbar ( it looks like the letter T ). Notice the Character Family section 
in the Properties window on the far right. Click inside the white box and type in the word Impact to 
change the font to a nice thick and bold typeface. Make sure the font size is at least 50 pt.

4. Click on your stage and type out the word “ABOUT”.
Then click up up Modify > Convert to Symbol…
Choose Button as the type and “about button” as your name.



   

Double click on the text - now you’re inside the button on a new timeline.

Create a new layer (found at the bottom baseline of your timeline, it looks like a piece of paper with a 
fold in it)… 

 

Rename this layer BG, then rename your original layer text, this is just for you to quickly tell the 
difference, make sure the text layer is on top.



Now select your second layer (BG).

Select the Rectangle tool.

5. Now change the Fill color from your Properties window on 
the right, click on the colored box choose a color (different than 
your text color).

Increase the Stroke number by typing it in the far right box or by dragging the slider to the right, this 
will create a thick outline around the shape we will be creating as the background to our button 
(anywhere between 4 and 6 will do).

Just below the FILL AND STROKE section is the RECTANGLE OPTIONS, click on the arrow and 
drag the slider bar (at least 10 will do), this will round off your corners when you make the shape.



6. Now go to your stage and click and drag a shape around the text, any form will do. If you don’t like 
how it turned out, press Ctrl+Z to undo, then try again.

With the rectangle selected, you can also edit the colors of the outline and the fill color through the 
tool bar, the box next to the pencil and the box next to the bucket control the colors for the outlines 
and the paint, this goes for anything you have selected.

7. Your scene should look something like this:

With your own custom colors and button size of course.



Click and drag to select both your keys and hold down the ALT key while you click and drag the 
frames over. Repeat the process for the next two frames again and again.

     

8. Now go to the 2nd frame (Over).
Press Ctrl+a to select everything on that frame.
Go to Modify > Transform > Scale & Rotate…



Type in: 103%

9. Create a new layer.
Drag that layer to the bottom of the timeline.
Press F7.
We’ve now made a new level and inserted blank keyframes on all four frames so that any background 
effects we insert will be isolated to their own frame.

   

10. Go to frame 2 (Over), Drag the keyframe to the BG layer down to the bottom layer (while holding 
down the ALT key).

Make the top two layers invisible by click in the “eye” icons.
Rename the bottom layer “effects”

11. With the rectangle still selected, go to the colors from your tool bar, remove the outline color by 
choosing the strike out box from the pencil’s color box, and change the fill color to white by clicking 
on the paint bucket color box and choosing the white color. See image below.



   

12. Now with the rectangle still selected, press F8 (to convert this into a symbol.
Name this symbol “over glow effect”… and change the Type to MOVIE CLIP. Click OK.

Double Click on this newly made symbol with your Selection tool.  Now that you’re inside this 
symbol, Press F8 AGAIN.  Name this symbol “glow”, again, keep it as a movie clip. With this symbol 
still selected… a Filters tab should now be present in the far right window (you may have to scroll 
down the Properties list to see it).

13. Make a new Filter and choose Glow. Change the settings to about Blur: 50, Strength: 150, 
Quality: High, and Color: white



With this done, go up to the timeline, select the first keyframe, then (while holding down ALT) drag 
this key over to frame 10, then repeat and drag it again to frame 20.  Now you’ve made two 
duplicates. Frames 1, 10, 20, all have three copies of the same glowing white rectangle.

14. Click and drag to select frames 1 to 10. Right click on any of those frames and choose Create 
Classic Tween.  Now that a tween is created we can alter one of these keys so that Flash will 
automatically make the graphics go into a glowing motion for when we hover our mouse cursor over 
this button later.  

Let’s select the middle keyframe on frame 10. Go to Modify > Transform > Scale & Rotate…
Choose 105%



   

You can scroll through the timeline to see the animated glow in action (or press Ctrl+Enter to see a 
preview).

15. Click on the about button section under your tool bar to return to that previous timeline.

Click on the 3rd frame (Down) from the BG layer, 
you may un-hide the top two layers.

16. Change the stroke and fill colors from the tool bar to different colors from the color palette.

 
Now you’ve completed the “Down” version of your button for when you click on it.

Click on the Scene 1 tab to return to the main timeline.



With the Selection tool (V), click and drag (while holding down the ALT key) the “ABOUT” button.
Drag it down, and do this again twice more. Now you have 4 identical buttons.



17. Now to customize each one.
Select the second button, and press the Swap… button in the top right corner from your Properties 
window.

Now press the button at the bottom of the pop-up window, and rename the button to “Photo button” 
(or graphics, or projects, or whatever you’d like).

Repeat the process for each button, swapping it out for a renamed duplicate. In this sample the 3 



additional buttons were named Photos, Resume, and Contact.  

If you forget what each one was designated, selecting the button and observing it’s name in the 
Properties window on the top right, will tell you which button you named it.

18. Now to make alterations to each button so that they match their names.
Double click on the second button to change the text for your photos button.

Go to the text layer and change the text to PHOTOGRAPHY (or whatever other title of works you’d 
like your website to showcase).

Now go to each frame, and alter the text in the same way, on the last frame (Hit) delete the text 
entirely, the Hit frame is only the surface area that the button is actually affected by, so there’s no 
need of text on this invisible frame.



With the text now modified on each frame, lock the text layer.

 

19. With the Selection Tool (V) - click and drag a selection box on the right half of the first frame’s 
colored rectangle. Then while holding down Shift press the right arrow keys to shift over that portion 
of the rectangle.



Once it’s in position (moved past the edge of your new text), with your Selection tool, click and drag 
the corners of the rectangle to meet up with the left half.

20. Now activate the Onion Skin button (found between the timeline and the toolbar).
Now you can see a watermark version of the frames before and after the frame you are currently on.
Click on the second frame (of the second layer). You should now see a ghost image of the 
rectangle you had edited earlier, pretend this is your guide, and repeat the process to match up this 
frame’s background as well.

With the Selection Tool (V) - click and drag a selection box on the right half of the first frame’s 
colored rectangle. Then while holding down Shift press the right arrow keys to shift over that portion 
of the rectangle. Once it’s in position (moved past the edge of your new text), with your Selection 
tool, click and drag the corners of the rectangle to meet up with the left half.



Repeat the process for the following two frames.

21. Lock the top two layers, we need to isolate our glowing effects layer, since this is the movie clip 
layer, we need to approach in a different way. To edit the size of this background, you need to select 
it, reposition it in the center with the arrow keys, then press “Q” to activate the Free Transform 
tool. Click and drag on of the side edges to extend it to the same size as your background color 
rectangle.

   



22. Repeat this process for your other two buttons. Click on the Scene 1 tab to return to the main 
timeline. 

Execute steps 18 to 21 for each of the other two button graphics.

In this sample… “resume (or CV)” and “contact” were the other two titles.  You may choose any texts 
you like for this mockup of a self-promotion website. You may even create more buttons if you’d like, 
repositioning them with the Selection tool (v) in any way you’d like.

23. Finally, add a main title to that blank top layer on your main timeline on Scene 1.
Rename the layer “title”, add some text, your name, your profession, whatever you’d like.
See how this simple layout turned out here: 
- Project Sample (Phase 1) -

Now you are going to being to add content to your website.

http://www.floobynooby.com/IPUB/sample1.html


Adding Scenes & Content To Your Webpage Layout

OK. So now we have a basic layout mapped out. Take the website you created from Test 11 and add 
on to it. We just need to prepare all your content, photos, bios, text, articles, illustrations, images, 
CVs, whatever information and items you want to show off on your own personal portfolio website.

First of all, lets replace the background with something a new.

OPEN PHOTOSHOP!

24. Before we can actually get started on the lighting effects, we need to create a background for the 
effect. We can’t simply use any background we choose, but rather create an appropriate canvas to 
begin with. Find a photograph to use as the basic palette for your background. It can be any image 
really… just make sure it has a lot of lights and darks in it. Alternatively, you can download the photo 
sample and work with the one used in the tutorial below: 
http://www.floobynooby.com/IPUB/forest-photo.jpg

http://www.floobynooby.com/IPUB/forest-photo.jpg


Open this forest photo in Photoshop (or ANY photo you’d like, it really doesn’t matter, as long as it’s 
nice and big).

25. From here, we need to apply a very strong Gaussian Blur to our Photograph. Go to Filter > Blur 
> Gaussian Blur, and bring the slider to something high. You really want to get rid of all the detail in 
the photo, and have all the colors mesh together. I applied a Gaussian Blur of 75.



Now we are going to drastically change our background by adding a Color Balance Adjustment Layer. 
To create this layer, go to Layer > New Adjustment Layer > Color Balance. A “New Layer” box 
may pop up, just click OK. Next you’ll see in your Adjustments tab on the far right of the screen 
having 3 different sliders, as well as 3 separate ranges to choose from (Shadows, Midtones, and 
Highlights). At this point, it’s really just about experimenting with the sliders in each range until you 
find a suitable result. If you’re using the photograph I supplied, these were the values I used: 
Shadows: -37, -40, 7 Midtones: 15, 62, 0 Highlights: -34, 0, 69



26. So now that we’ve completed our simple,blurry/abstract BG art, save the file. File > Save As > 
name the file “BG” and change the format to JPG.

Open your Flash website layout you prepared last week with basic buttons and title.
Make sure your background layer is unlocked, click on the keyframe (thus selecting the temporary 
gradient you had created) and press Delete to remove.

  

Now go to File > Import > Import to Stage…
Choose the JPG image you created from Photoshop.

It should line up perfectly to the top left corner, if it’s not covering your white canvas, press ‘Q’ to 
activate the Transform tool and expand (or shrink) the image to fit.

If you’d like to find a cool image on the internet to use, that’s fine too, anything to make a nice, simple, 
appealing graphic for your backdrop.



Phase 2
Step 1

Change the ESSENTIALS tab in the top right corner to ANIMATOR, to make things easier for you to 
navigate around.



Go to the Scenes tab on the left and make 4 new scenes by clicking on the tiny paper icon on the 
bottom left four times.

Step 2

Now you have 5 scenes, click on Scene 1.
Lock all your layer except the ‘buttons’ one.

Right click on your first button on the stage (mine was the ABOUT button).
Choose Actions.



Make certain your Script Assist button is activated (you’ll know if there’s a big blank area above it).

*Note: Since version CS5, this has moved to the tiny menu button in the top right corner of the 
Actions window, simply click on it to make sure the "Script Assist" text is check-marked, otherwise 
proceed as normal.

Look to the left side > under Global Functions > Timeline Control click and drag the “goto” text to 
the mini stage on the right.



Now go up to the Scene: section above and to the far right click the arrow to select Scene 2 from the 
drop down menu.

To return to your timeline, click on the tab at the top.

Repeat this process 2 or 3 more times for the remainder of your buttons.



For each button have it go to the next scene.

Step 3

Now you’ve finished selecting, right clicking > Actions for every one of your buttons, setting them to 
go to a separate scene.  Now let’s get those scenes ready for you to add your stuff into them.

First, click on Scene 2.

Create a couple new layers.



Rename the bottom layer “background” (double click on the text of the layer to rename it).

Zoom out (press M, then hold down ALT and click on the stage) now you can see all four corners of 
the stage clearly.

Choose the Rectangle tool.

Go to the stage and click and drag from one corner to the next, cover all the white of the canvas.



Step 4

Now to customize the paint of this backdrop.
Go to the far left and in the Color tab, choose Radial for your Type.



Now click on the first color tab to pick a new color for the start of your gradient.

After choosing your two different colors, you can now grab the Paint Bucket tool and paint the 
rectangle with it.



Wherever you click, that’s where the gradient will begin.

Step 5

Lock that background layer when you’re done tinkering with it.
Click on the next layer up, then go to the Text tool, and click on the stage.

Don’t worry you’ll be able to move the block of text later.

Start typing (or copy/paste from a previously written document) or Bio, or the purpose of this site, or 
an introduction to your work experience and why this site is created and viewed. Basically, a generic 
cover letter of sorts.





When you’re done writing your blurb of text, grab the selection tool to drag the text to the right spot.

Step 6

To change the font, size and color (now that you still have the text selected, go to the right, you’ll see 
the Properties window has many different options for you to customize your text.



Step 7

With your text finalized, lock that middle layer on your timeline, rename it “text”, and rename the top 
layer “button”, then select that layer.



Now we must create a back button to get back to the main page (clear and easy navigation through 
someone’s website is important).

Select the Text tool, click on the stage, type out “BACK”.
Select the text, go to Modify > Convert to Symbol…  Choose Button for the Type and name the 
symbol “back button”.

Step 8

Make a new layer and drag that layer underneath of your text.
Now we’re ready to add a box behind the text.



Select the Rectangle tool, pick your colors, and click and drag a shape around the text on the stage.

Nice and simple, now we can complete the button by selecting the two key frames, and drag them 
over to the next frame (while holding down the ALT key).



Do the usual customization of your button any way you’d like, larger smaller, different colors, 
whatever for each frame, but leave the “HIT” frame alone, that the area that is affected by your 
button.

To go back to the main timeline for this scene, click on the “Scene 2” button under your timeline.

 
Step 9

Right click on your BACK button, choose Actions and go through the same process as usual; drag the 
“goto” text to the white area, and change the Scene: to Scene 1.



Now from the SCENE tab on the far left of your screen, click on Scene 3.  This is the scene for my 
Photography button, but it could be your Graphic Design section or whatever you wish (make sure the 
button matches the scene.  You must now start to import your content, you have all your content 
ready right?…. right?  Ok, let’s assume you do. 

Step 10

If you’re importing your own personal graphics, logos, illustrations, designs, or photographs, make 
sure you resave them from Photoshop first and make sure you shrink them down first before 
importing them into Flash; A) because it will make the file load up faster for when you publish your 
site, and B) to make the file more manageable and by keeping it low resolution makes it a deterrent 
for anyone who would try to steal your work.

To import your bitmaps, you do so in the same way you imported that Photoshop background earlier. 
File > Import > Import to Library…
Select your file(s), click OK, they will appear on your stage.



Everything you import, whether it be audio, video or images, get stored in the Library including all the 
symbol you create. 

Step 11

So once you imported all your photos – open your Library tab.
You can click and drag the individual images from the Library window to your stage. You can choose 
one at a time, or several (I imported 6 images, and I’m placing 3 per page).

Make a new layer. Create a background for it (same way you did earlier, or copy and paste it from 
Scene 2).

Make another new layer, name it “buttons” (rename your other layers while you’re at it so you don’t 



get lost)

With your colored background gradient, your photo(s) setup, now we need to navigate through these 
images, and lay out some more.

Step 12

Click and drag to select all 3 frames from the first to the last layer.

Then press F5 to add a frame.

Now select the second frame of the second layer, press F6, then DELETE.
If it didn’t wipe out the photos you had, then just unlock the photos layer and hit DELETE again.

Now drag on the new set (or individual) photo of your choice.

The arrangement, number of photos/graphics, and layout/colors you choose are entirely up to you.



Now lock your photos layer and select the first frame of the top layer.

Create a NEXT button in the same way you created the BACK button earlier…

Step 13

Select the Text tool, click on the stage, type out “NEXT”.
Select the text, go to Modify > Convert to Symbol…  Choose Button for the Type and name the 
symbol “next button”. Make a new layer and drag that layer underneath of your text.
Now we’re ready to add a box behind the text.

Select the Rectangle tool (or the Oval tool), pick your colors, and click and drag a shape around the 
text on the stage.

Nice and simple, now we can complete the button by selecting the two key frames, and drag them 
over to the next frame (while holding down the ALT key).

Do the usual customization of your button any way you’d like, larger smaller, different colors, 
whatever for each frame, but leave the “HIT” frame alone, that the area that is affected by your 
button.

To go back to the main timeine for this scene, click on the “Scene 3” button under your timeline.
Right click on your NEXT button, choose Actions and go through the same process as usual; drag 
the “goto” text to the white area, but this time choose Type: “Next Frame”.



Step 14

Still with the Library open, and working on the top layer, click and drag your old BACK button and 
place it on the stage somewhere.

Right click on your BACK button, choose Actions and go through the same process as usual; drag 
the “goto” text to the white area, and change the Scene: to Scene 1.

You can unlock the photos layer and keep adding more and more content, press F5 to add frame on 
the timeline, if you make a mistake Ctl+Z to UNDO.  If you accidentally double click and it brings you 
into the symbol, you can just double click anywhere on the stage to bring you back where you were.



Step 15

Repeat the last process in a similar way for your next scene (my website was setup to be the 
Resume for the 3rd button). Click on Scene 4 in the far left tab to get into that fresh new timeline. 
Copy/paste your old background (or create a new one), create a new layer, copy/paste your resume 
(or at least a condensed version of one) into a block of text. Make sure to add a layer for your back 
button, drag the symbol in from your Library, set it to go back to Scene 1.

Now all we need to do is fill out our contact info.

Click on the Scene 5 text to the far left of your screen.

Type out your email address, plus any other info you’d like to share, your Linkedin address, your 
phone number, your Twitter, your MSN Messenger, your Skype, your iChat, etc.



Step 16

Once you’ve setup your email text…

Select the text, go to Modify > Convert to Symbol…  Choose Button for the Type and name the 
symbol “email button”.

Make a new layer and drag that layer underneath of your text.
Now we’re ready to add a box behind the text.

Select the Rectangle tool, pick your colors, and click and drag a shape around the text on the stage.

Nice and simple, now we can complete the button by selecting the two key frames, and drag them 
over to the next frame (while holding down the ALT key).

Do the usual customization of your button any way you’d like, larger smaller, different colors, 
whatever for each frame, but leave the “HIT” frame alone, that the area that is affected by your 
button. To go back to the main timeine for this scene, click on the “Scene 5” button under your 
timeline.

Right click on your email button choose Actions, and choose 
Global Functions > Browser Network > getURL  
Type this in the URL slot: mailto:"your@email.address.com"  (add in your e-mail address in these 
quotations). This will make it so a visitor to your site will have their email program pop open ready to 
write to you directly once they click on the button.

Go back to your Timeline tab (at the very top).
Don’t forget to drag in and setup your Back button again (or you can copy/paste it from another 
scene).



Step 17

Return to Scene 1.
Now we have to set all our scenes to stop once the scene is activated.
At your main title page, go to the one keyframe on the top layer, right click on it and choose Actions.
Then click and drag in “stop” from the Timeline Control section.

When you go back to the Timeline, you’ll notice there’s a small “a” on the keyframe, meaning there’s 
an action on the timeline.



Now go and do this to ALL your other scenes. Go click on Scene 2, right click on the first 
frame, select Actions, drag the “stop” command to the white area, and repeat for the rest of 
them.

Step 18

Now to get rid of that hideous text you made.
To create a new stylish title, let’s delete the old one by locking all layers except for the one with your 
title on it, click on the keyframe and hit delete.

Now open up PHOTOSHOP for a quick simple text effect tutorial on “layer styles”.

Step 19

File > New
Create a new document with these dimensions:
1000 pixels Width, 500 pixels height, 150 dpi Resolution.
Click OK.

Grab the paint bucket and paint in a color for the background (just so you 
can see what you’re doing), I chose a red color.
Now, lets create some text, the font I'm using is Verdana, but you can 
use any sans serif font like Helvetica, Arial, or anything like that. Grab a 
yellow-orange color for the font.



Go into your layer styles.
Found in the fx button in the far bottom right corner of your 
layers window.  [If you can’t find th Layers tab go to Windows > 
layers menu]
Now lets go to the bevel and emboss settings. 



Create a bevel with these settings.



Now go into the gradient overlay settings of the layer styles. Choose these settings.

After setting the colors, click OK, and OK again, your window will look like this:

Finally, go into the drop shadow settings of the layer styles and change your settings to something 
like I have below.





Now to prepare it for Flash, make your background invisible by removing the eye icon on the bottom 
layer.  Then go to File > Save As… and choose the PNG format. Name your file title.png
If the “Interlaced” options pops up, select it and press OK.



Step 20

Back to FLASH.

Make sure you’re on the top layer. Go to File > Import > Import to Stage…
Choose your title.png image. Click OK.

BAM you’ve got a transparent background on your awesome bitmap text.

That’s the power of the PNG file, it preserves the “alpha channel” and eliminates the background you 
had.

Reposition the text, and blammo! … You’re done! Press Ctrl+Enter to test your movie
Well… sort of.  Keep tweaking and improving, check to see if all the buttons work and do what they’re 
supposed to do.  This is your final exam (worth 50% of your grade).  Consistency, free of errors, and 
a nice easy-to-navigate layout are the key factors.  It should function like this: - Website Sample -

If you don’t like the main background art, go online and find something else you like, import it in and 

http://www.floobynooby.com/IPUB/assignment9-sample.swf


replace the old background JPG with a new one, whatever you’d like.

You can keep on adding and adjusting it to your liking.

The following is entirely optional
The rest of this document is not mandatory to do and is only additional theory on how to proceed in 
preparing this file for the web. 

This is all “For Your Information”, You still would need to purchase or acquire some web space in 
order to post up your website like this, but these are the next step.

Open up Adobe Dreamweaver.

When the program fires up, choose HTML as your new document.

You’ll have a blank page, make sure the “Split” button is on, you’ll know cause you’ll see some code 
on the screen.

Now type in the “embed code”  You can copy/paste it from the text below, just replace 
“yourwebsite” with the name of your flash file. Make sure .swf is at the end. Note: it’s the rendered 
movie file we’re embedding not the Flash file itself.

<embed src="yourwebsite.swf" type="application/x-shockwave-flash" 
pluginspage="http://www.macromedia.com/go/getflashplayer" height="480" width="853">



Label your file with “your name” and then “index” afterwards (as shown above DO NOT USE 
SPACES), save it in the same location as your Flash file and SWF file. Open the HTML file in Firefox 
to test it out. If you wish to make the website centered, add in some <center> open and close tags as 
shown below.

For more on basic coding with HTML go here:

http://www.web-source.net/html_codes_chart.htm

That’s it!
This is VERY basic, but still you can see how long it can take to make a website, a very simple one 
can be done in an hour, but once you add more content, graphics and information it can take several 
days, not to mention how sophisticated your imagery and graphics can be.

Send the HTML and SWF files 
(with your name in both of the actual file names) to your instructor.

OK, so now we’ve made an SWF file (the rendered all-in-one-self-contained rendered Flash movie file 
that holds all your scenes, buttons, text and pictures), and we’ve learned the basics of Dreamweaver. 
Once you have all your content ready to upload, there are a number of open source venues available 
to you, all without any requirement of prior programming knowledge. 

The following is information for you to keep for when you want to take the plunge and actually 
PUBLISH your website online.  It’s not entirely that easy (depending on which route you take), but 
once it’s up it’s very easy to maintain, upkeep and update.  Whether you go the simple route or the 
hardcore route, the better your website looks and feels the better chance you have at getting a job 
with it.  It shows you’re professional and care about your own self-marketing/promoting skills.  It can 
be a lot of work but it’s well worth it once it’s done.

http://www.web-source.net/html_codes_chart.htm


The remainder of this document is not mandatory for you to do, it is only advice for you to use if ever 
you plan to continue your endeavors in developing and managing your own website. 

1. Creating your website

Using Wordpress (one of the best hosting companies out there)

www.Wordpress.org is one of many free content management system that is used by millions of blogging laymen. With it 
comes a whole system that makes it easy to add new content to your site and already made web design themes for you to 
choose between. Alternatively, learn more about how to create your own Wordpress theme and full blown website by 
downloading Wordpress to construct your site in full: www.wordpress.com (this is where you could upload your all-
inclusive SWF file and BAM you’re done!  …. Um, once you’ve registered your own domain name and all that first).

If all you want is a very simple, point and click web site to post your words and pictures and nothing else, then 
www.blogger.com is your best bet. Easy and simple to use, many photographers even go this root to make a fast and 
efficient online portfolio to showcase some samples of their photography.  Blogs are VERY simple but limited, if you have 
your resume, pictures and all that ready, then you don’t need Flash or Dreamweaver, blogger will take care of the layout, 
template and everything for you.  You don’t get your own “.com” and your choice of colors, layouts and aesthetics are a bit 
limited

Joomla is another free CMS software which basically creates the site for you and eases the task of content administration. 
The only thing you have to do is to install it properly. In addition to this, you are also normally granted free access to site-
building tools when you sign up for a hosting plan. If you want read more about how to start your own website, find out 
more about how to set up a free website through web hosting here: http://www.webhostingsearch.com/articles/how-
to-start-up-a-website.php

Refresher on the basic nerd terminology you should know as you get into actually publishing 
and managing your own personal website:

Domain – Refers to the initial part of a URL (Uniform Resource Locator. The unique address of any Web document found 
online), where the domain and name of the host or  server computer are listed (most often in reversed order, name first, 
then domain). The domain name gives you who "published" a page, made it public by putting it on the Web.

CSS – Cascading Style Sheets – a file ending in .css, which is linked to from the HTML, which controls the look of the 
rendered page. In Dreamweaver when you construct a page with lots of tables and imported elements like images, 
sounds, etc, CSS files are created automatically to keep track of all the elements.

HTML – Hyper Text Mark-up Language is the code that forms all websites and describes the content it contains. It is 
important to understand that ALL websites end up as some form of HTML, regardless of the languages used to build 
them. For example, a file might be PHP (Hypertext Preprocessor), as in index.php, but ultimately what is served up to the 
browser is HTML. The file extension PHP just lets the server know to process any of the special PHP code inside before 
serving it up.

FTP – File Transfer Protocol. Ability to transfer rapidly entire files from one computer to another, intact for viewing or other 
purposes.

Web Server – A computer running that software, assigned an IP address, and connected to the Internet so that it can 
provide documents via the World Wide Web. Also called HOST computer. Web servers are the closest equivalent to what 
in the print world is called the "publisher" of a print document. An important difference is that most print publishers 
carefully edit the content and quality of their publications in an effort to market them and future publications. This 
convention is not required in the Web world, where anyone can be a publisher; careful evaluation of Web pages is 
therefore mandatory.

CMS – Content Management System – a software program that runs on a server with the purpose of making managing 
the content on the website easier. For example, a site may have hundreds of pages (like this one). Each of those pages 
does not exist as a separate HTML file. Instead, the content is kept in a database and injected into templates and served 

http://www.webhostingsearch.com/articles/how-to-start-up-a-website.php
http://www.webhostingsearch.com/articles/how-to-start-up-a-website.php
http://www.blogger.com/
http://www.wordpress.com/
http://www.Wordpress.org/


up as needed by the CMS.

RSS – Really Simple Syndication is a special (and standards based) form of XML for publishing content. For example, 
most blogs provide RSS of their content. Other people (even basic users) can take that RSS and use it in different ways, 
like republishing that content elsewhere, or just reading it through special programs, like Google Reader). May be referred 
to an an RSS Feed, or even just Feed by itself.

Kerning – Adjusting the spacing between two specific letters, to improve how a word looks aesthetically. Tracking is 
similar but refers to overall letter spacing.

Sprite – An image that actually contains multiple images. The images are typically displayed cropped down to only show 
a small area. As counter-intuitive as it seems, this can improve efficiency by requiring less total images to be used.

Vector – A form of graphic where the design is saved as points and mathematical formulas. Because of this, the files are 
“resolution independent” meaning they can be scaled to any size without losing their crispness. Adobe Illustrator files are 
vector files (although it is possible for them to contain bitmap data). AI, EPS

Bitmap – A form of graphic that is saved as individual pixels, meaning it has a set resolution and cannot be scaled up or 
down without affecting its crispness. Adobe Photoshop files are bitmap files (although it is possible for them to contain 
vector data). JPG, GIF, PNG.

Rendering – the process the browser goes through when interpreting HTML and CSS and turning that into the visual end 
result you see on your screen. When a website is slowly ‘loading up’ you see text and images gradually appear, this is 
“rendering”

2. Get a hosting plan

Next step is to find somewhere online to put your website files and assign an address to that somewhere. Any given 
hosting plan include storage space on a web server and a domain name registration. Depending on what size your 
website has and potential traffic volume it's going to generate, you get a hosting plan based on three factors - storage 
space, bandwidth and CPU. Nowadays, there are many qualitative and cheap web hosting plans to choose between: 
http://www.webhostingsearch.com/cheap-web-hosting.php

For all of you into blogging, there are also many great WordPress web hosts offering cheap hosting that is tailored to 
support this CMS. 

*Overall WordPress is probably your best bet for a website/blog, it ranges from free to expensive, but if you want 
to build a web presence, you get what you pay for, try them out for free then explore to see what they have to 
offer for deals to make full blown websites.

3. Upload your files/Publish your website

Upload your files to the root directory of your purchased web hosting server space. You can do this either by using your 
hosting account's inhouse file manager, but those are often slow and manage large file volume poorly. Our recomendation 
is to get your hands on a FTP client. More specifically, a FireFox add-on by the name FireFTP. It will allow you to access 
your hosting account directly in the web browser and transfer website files with ease: http://fireftp.mozdev.org/

Assuming that you are new to web development, it is important for you to get a website up sooner rather than later, I 
suggest you follow the steps above. Use open source and the blessing of freeware. Get a hosting plan that matches your 
needs and publish your files through an FTP client like FireFtp. There will be things to remember and learn along the way, 
but if you follow these guidelines, publishing a website will not seem so impossible.

Basically you have 4 options, it’s all entirely up to you which one you pick:

1. Publish to a free subdomain and host your site with any online company that offers this service 
(like those shown in the huge list below).

http://fireftp.mozdev.org/
http://fireftp.mozdev.org/
http://www.webhostingsearch.com/wordpress-hosting.php
http://www.webhostingsearch.com/cheap-web-hosting.php


   2. Purchase a custom top level domain (.com, .net, .biz or .org) and still host your site with us for 
free.

   3. Publish to a domain you already own and still host your site with any free (on non-free) web 
hosting company.

   4. Say “screw that” and go for the simple, fast “Blog” method, upload you pictures and texts to a 
free blog, customize it the best way you can, spread the web address out to your friends, clients, and 
potential employers. 16 WordPress Sites to Help You Build a Better Blog: 
http://sixrevisions.com/wordpress/16-wordpress-sites-to-help-you-build-a-better-blog/#more-
1930

Remember:

   1. If you select options 1,2 or 3 you can easily make changes to your published site at any time, so 
there is no need to wait until your site is "finished" before you publish it. Good websites are always 
"under construction" and you should continue to update your site as often as possible after you 
publish it.

   2. When you publish your site anyone will be able to view your site by clicking on a link to your site 
that you provide, or by typing your URL (web address) into the address bar of their browser. 
However, you will not be able to search for your site immediately as it takes time for newly published 
sites to be indexed by search engines.

Below is a short list of names and reviews for online free web hosting:

  ZeroCatch 
One of the best free Web hosters that we've seen yet, ZeroCatch offers you 100 megs of space. This banner-ad 
supported hoster has speedy, reliable servers. Features here include FTP support, site promotion and more. If you're 
looking for an added draw for your site, check out their "partnership" program, which lets you become a free Web space 
provider yourself. 

  TopCities.com 
A solid free Web space provider, TopCities.com offers you 150 megabytes of space, unlimited bandwidth, and free 
subdomains. Here, you upload your files using FTP, or via their online EasyUpload utility. TopCities.com also offers a 
number of free enhancements for your site, such as a guestbook and a message board. 

  Hostrator 
A free Web hosting service that offers a generous 10 gigs of space, as well as free subdomains. You can upload your 
content either via your browser or FTP. Hostrator offers 24/7 tech support via E-mail. The service supports PHP and 
MySQL. 

  BlackAppleHost.com 
A new free Web hosting service that offers a hefty 5 gigs of space and instant account activation. You can upload your 
content here either via your browser or FTP. BlackAppleHost.com offers lots of features, including detailed traffic stats, as 
well as support for MySQL and PHP. 

http://www.blackapplehost.com/
http://www.hostrator.com/
http://www.topcities.com/
http://www.0catch.com/
http://sixrevisions.com/wordpress/16-wordpress-sites-to-help-you-build-a-better-blog/#more-1930
http://sixrevisions.com/wordpress/16-wordpress-sites-to-help-you-build-a-better-blog/#more-1930


  Hostse 
A free hosting service that gives you a generous 1 gig of disk space, as well as 25 gigs of bandwidth. Hostse offers PHP 5 
support, MySQL databases and full FTP access. You may either use your own domain (if you have one), or get a free 
subdomain. 

  007sites.com 
This is a speedy free Web hosting service that gives you 700 megabytes of space and 7,000 megs of monthly bandwidth. 
Here, you can get your own subdomain (or you can use your own existing domain). 007sites.com also offers MySQL, 
PHP, and FTP support. 

  FreeWebPage.org 
This is a solid, free Web hosting service that includes a lot of helpful features. An ad-supported service, 
FreeWebPage.org gives you 150 megs of space and your own subdomain. Other features include direct FTP access, a 
guestbook, a message board, form mail and lots more. 

  250Free.com 
A fast-growing free Web hosting service that offers 250 megs of space, as well as top-notch tech support. 250Free.com 
features an easy-to-use Web-based account manager, as well as FTP access. This service is MSN TV-friendly. 

  1SweetHost.com 
Here's a free, banner-supported Web hosting service that offers you 100 megs of space, along with FTP support, site 
promotion, and speedy servers. 

  WebNG.com 
This free hosting service offers 350 megs of space and speedy servers. Features here include FTP access, ASP 3.0, SSI, 
and Microsoft Access database support, along with image, audio and video hosting support. 

  ProHosting.com 
This free Web space provider offers a generous package. Here, you get 50 megs of Web space, an FTP account and CGI 
access. ProHosting also offers an online site creation utility and customer support via E-mail. 

  Orgfree.com 
Here's a versatile free Web hoster that features domain and subdomain hosting. This service offers "unlimited" Web 
space and bandwidth and high-traffic sites are eligible for a free domain. Here, you get free FTP access, PHP/MySQL 
support and more. 

  Free-Webhosts.com 
Are you looking for free Web space? This regularly-updated directory lists over 800 free hosting services on the Web. 
Free-Webhosts.com offers reviews, ratings and a searchable database. 

  Absolutely-Free-Hosting.com 
Here's a good resource if you're looking for free Web hosting. This site offers a searchable database with reviews of over 
200 free hosting services on the Web. The categories here round up hosters by the specific services they offer, including 
ASP, PHP, domain hosting and more. 

  eSmartStart.com 
A speedy, solid free hosting service which offers 20 megabytes of Web space for your personal or commercial Web site. 
Esmartstart.com lets you use your own domain name or you may choose from among 12 virtual domains. Here, you get 
full FTP access, as well as an easy-to-use Web-based file manager. Other features include unlimited E-mail addresses, a 
guestbook, counter, templates and more. Excellent tech support is provided via E-mail.

http://www.esmartstart.com/
http://www.Absolutely-Free-Hosting.com/
http://www.free-webhosts.com/
http://www.orgfree.com/
http://free.prohosting.com/
http://www.webng.com/
http://www.1sweethost.com/
http://www.250Free.com/
http://www.freewebpage.org/
http://www.007sites.com/
http://www.hostse.com/


  987mb.com 
This popular free hosting service offers 1,987 megs of Web space, as well as instant activation of new sites. 987mb.com 
has lots of useful features, including MySQL, PHP, a mailbox, tracking stats, and five free subdomains. 

  Profuse Host 
At this free Web hosting service, you get 1,000 megs of space, as well as 100 gigs of monthly bandwidth. Profuse Host 
offers lots of useful features, including free domain hosting, PHP/MySQL support, CGI access, and more. 

  FindMyFreeHost.com 
This helpful directory offers a nice roundup of free hosting services on the Web. Here, you'll also find listings for 
commercial hosters, as well as other hosting-related services, such as free domain names and URL hosting services. 

  PurePortals.com 
This free, ad-supported service lets you set up your own portal, complete with features like Web logs, photo galleries, 
contact lists, announcements, news feeds and more. You also have the option of using your own domain name for your 
portal at no extra cost. 

  Free Web Hosting Search 
This search engine can help you find a free Web hosting service that fits your needs. Here, you can search by specific 
features, including ASP, PHP, CGI, MySQL, and more. This site also includes details about the pros and cons of each 
service. 

  00FreeHost.com 
A speedy free Web hosting service that gives you 100 megs of space and your choice of FTP or browser upload access. 
Here, you also get free site stats, site promotion help, and your own subdomain address. 

  Free-Webspace.org 
Looking for free hosting for your Web site? This searchable directory offers a good roundup of various free hosters across 
the Net, along with detailed listings of each service. 

  Best Free Web Space 
This Web space directory offers reviews, descriptions, and ratings of over 100 free hosting companies on the Web, along 
with a searchable database. 

  1ASPHost.com 
This free Web hosting service offers 100 megs of space, unlimited bandwidth and instant account activation. Features 
here include Microsoft Access database support; Active Server Pages (ASP) and 24-hour tech support. 

  ImageUploads.com 
A free image hosting service, ImageUploads is easy to use and allows hotlinking. This service is handy for posting 
pictures on Web sites, forums, eBay auctions, etc. Supported image formats include GIF, JPG and SWF. 

  FreeWebSiteProviders.com 
Looking for a free Web hosting service? This handy directory offers reviews of over 400 free hosters across the Web. The 
site also features a roundup of free Webmaster services, such as Web page templates, URL redirection services, 
counters, hosted CGI scripts, graphics and more. 

  Blogger.com

http://www.blogger.com/
http://www.freewebsiteproviders.com/
http://www.imageuploads.net/
http://www.1asphost.com/
http://www.100-Best-Free-Webspace.com/
http://www.free-webspace.org/
http://www.00freeweb.com/
http://www.freewebhostingsearch.com/
http://www.pureportals.com/
http://www.findmyfreehost.com/
http://www.profusehost.net/
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 Would you like to publish on the Web, but don't want the hassle of having to set up a Web site? Then you should explore 
Blogger, a free online tool that lets you post content on the Web instantly. Blogger, a popular service owned by the search 
engine Google, lets you quickly and easily set up a custom "blog" (short for "Web log"). 

  FreeWebSpace.com 
A solid, free, ad-supported Web hosting service, FreeWebSpace.com gives you 100 megs of space, along with site 
promotion and enhancement tools. You can use either their Web-based file manager, or an FTP client, to upload your 
files. 

  FortuneCity.com 
Stake your claim at this major free Web space provider that uses a city theme. Some people will probably find this 
concept appealing; others are annoyed by it, judging from our feedback. Fortune City.com offers 1 gig of space and 
they've added subdirectory support, making it easier to manage your files.

  Angelfire.com 
A major free Web space provider that is owned by search portal Lycos, Angelfire offers 20 megabytes of space and 
supports FrontPage extensions. You may advertise your business here, but you may not have paid advertising banners 
on your page. Angelfire offers lots of helpful advice for getting you up and running with your own Web site, even if you're 
new to Web site authoring. 

  WebSpawner.com 
WebSpawner is a free online Web authoring system that lets you design and develop customized Web pages in a matter 
of minutes - without having to learn HTML. 

SPEND MONEY – GET MORE BANDWIDTH AND SPEED 
FOR $4+ PER MONTH:

http://www.hostmonster.com/

http://www.arvixe.com/

http://www.hostclear.com/

http://www.fatcow.com/

http://www.justhost.com/

http://www.zooloo.com/

http://www.godaddy.com
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